RFC 485 UNKNOWN MIX · SOFTWARE

MIX and MIXAL at UCSB

A UCSB report on a MIXAL assembler and a partly debugged MIX simulator.

On rfc-editor.org ↗
PUBLISHED
March 1973
AUTHORS
J.R. Pickens
STREAM
Legacy
DOI
10.17487/RFC0485

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
Network Working Group                                    John R. Pickens
RFC # 485                                                UCSB
NIC # 15063                                              19 March 1973
References NWG/RFC #473


                         MIX and MIXAL at UCSB

The following, in response to David Walden's MIX query (RFC#473) was
written by a graduate student at UCSB.  Questions regarding "cheap"
usage should be directed to Roland F. Bryan (RFB) at UCSB.
-----------------------------------------------------------------------

Mark Scott Johnson
18 March 1973

    I wrote a MIXAL assembler and a MIX simulator last summer.  The
assembler is written in SNOBOL4 and, unfortunately, is fairly expensive
to run.  The assembler has been fairly well debugged and is documented.
However, although the MIX simulator is written (in 360 Assembler), it
has only been partially debugged.  Due to the resumption of school and
other commitments, I was unable to give the simulator a thorough
debugging.  All the simulated instructions except I/O instructions have
been tested somewhat and appear to be operating well.  Also, card reader
input and printer output are operational, but my simulation of disk
files and magnetic tape has not been completed.  There is presently no
documentation for the simulator.  Very little documentation is needed,
however, since the simulator follows almost to the letter the
specifications detailed in _Fundamental_Algorithms_.

    If anyone is interested in using the assembler and/or the simulator,
I will be happy to supply what documentation exists plus some
information on how the programs can be accessed.  Also, if anyone is
interested in the source code for the programs, I will be happy to send
it.  I hope to be able to finish the simulator this next quarter.  If
anyone wants to use the system and if they should find any bugs, I will
do my best to maintain and correct the programs.





       [ This RFC was put into machine readable form for entry ]
       [ into the online RFC archives by Alex McKenzie with    ]
       [ support from GTE, formerly BBN Corp.             9/99 ]

ISO Plain Language

On this page
PROBLEMRFC 473 asked whether Network hosts had software for Knuth's MIX computer and its MIXAL assembly language.
MECHANISMA UCSB graduate student reports an assembler written in SNOBOL4 and a simulator written in 360 Assembler, and offers information and source code.
THE STATUSThe assembler was fairly well debugged and documented; the simulator was only partly debugged and lacked documentation.

§1A Reply About MIX

John Pickens forwards a response to David Walden's question in RFC 473 about MIX and MIXAL tools. The response was written by UCSB graduate student Mark Scott Johnson.

The note directs questions about inexpensive use to Roland F. Bryan at UCSB.

A UCSB student answers the network's request for MIX software. The RFC passes on his description and contact information.

§2Assembler and Simulator

Johnson says he wrote a MIXAL assembler in SNOBOL4 and a MIX simulator in 360 Assembler. The assembler was fairly well debugged and had documentation, though it was expensive to run.

The simulator was only partly debugged. Instructions other than I/O had been tested somewhat, while disk-file and magnetic-tape simulation were incomplete.

The assembler was more complete but costly to run. The simulator still needed testing and did not yet support all described features.

§3Offer to Share the Programs

Johnson offers to provide the documentation that existed, information about accessing the programs, and their source code. He hoped to finish the simulator in the next quarter and said he would try to maintain and correct the programs if users found bugs.

The author offered to share the programs and existing instructions. He also invited users to report problems so he could try to fix them.