RFC 548 UNKNOWN OPERATIONS · HOST-IMP INTERFACE

Hosts using the IMP Going Down message

A request for Hosts to notify users about an impending local IMP outage.

On rfc-editor.org ↗
PUBLISHED
August 1973
AUTHORS
D.C. Walden
STREAM
Legacy
MAINTENANCE WINDOW
Tuesday, 7 a.m. to 9 a.m. Eastern Time
DOI
10.17487/RFC0548

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
Network Working Group                                    D. Walden
RFC # 548                                                BBN-NET
NIC # 17794                                              August 16, 1973


                 Hosts Using the IMP Going Down Message


    As given in BBN Report 1822 (Specifications for the Interconnection
of a Host and an IMP), IMP to Host message type 2 specifies that the IMP
local to the Host is going down; the message further says when the IMP
is going down, for how long, and why.

    When the IMP goes down after sending the IMP Going Down message to
the Host, the Host's network users and local users of the network will
not, in general, be forewarned unless the Host sends a message to these
users.  We therefore urge all Hosts to warn their network users and
users of the network of impending IMP downs; just logging the received
IMP Going Down message on a logging teletype, as many Hosts currently
do, seems insufficient.

    Incidentally, please remember that Tuesday mornings from 7 a.m. to 9
a.m.  (Eastern Time) are reserved for Network Software Maintenance, as
announced in RFC #440.










       [ This RFC was put into machine readable form for entry ]
       [ into the online RFC archives by Alex McKenzie with    ]
       [ support from GTE, formerly BBN Corp.            10/99 ]

ISO Plain Language

On this page
PROBLEMUsers were not generally warned when their local IMP sent a message that it was going down.
MECHANISMThe RFC urges Hosts to relay the IMP Going Down message to network and local network users instead of only logging it.
USER NOTIFICATIONThe note also reminds readers that Tuesday mornings are reserved for network software maintenance.

§1The IMP Going Down Message

BBN Report 1822 defines IMP-to-Host message type 2 as the IMP Going Down message. It tells the Host when the local IMP will go down, for how long, and why.

The IMP sends its Host a message about an upcoming shutdown. The message includes when it will happen, how long it will last, and why.

§2Hosts Should Warn Their Users

The RFC says users will not generally be forewarned unless the Host sends them a message. It urges Hosts to warn both network users and local users of the network when they receive the IMP Going Down message.

The author says merely logging the received message on a teletype, as many Hosts did, seems insufficient.

Hosts should pass the outage warning on to their users. Simply recording it on a teletype does not reliably warn people.

§3Network Software Maintenance Window

The RFC reminds readers that Tuesday mornings from 7 a.m. to 9 a.m. Eastern Time are reserved for Network Software Maintenance, as announced in RFC 440.

The notice reminds readers of a regular network software maintenance window. It is Tuesday from 7 to 9 a.m. Eastern Time.