RFC 331 UNKNOWN ARPANET · OPERATIONS · MAINTENANCE

IMP System Change Notification

A planned BBN software change for the ARPANET's IMPs.

On rfc-editor.org ↗
PUBLISHED
April 1972
AUTHORS
J.M. McQuillan
STREAM
Legacy
OBSOLETED BY
RFC 343 — IMP System change notification
PLANNED RELEASE
IMPSYS 2600
PLANNED SWITCHOVER
May 15, 1972, noon to 3 p.m. E.D.T.
SYSTEM TO RELOAD IF PROBLEMS DEVELOPED
IMPSYS 2514
DOI
10.17487/RFC0331

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
Network Working Group                              J. McQuillan
RFC #331                                           BBN-NET
NIC #9924                                          19 April 1972
Category:  B.1

                     IMP System Change Notification

     We are planning to release IMPSYS 2600 on May 15, 1972, be- tween
12 noon and 3 p.m. E.D.T.  As discussed at the March 16 seminar held
at BBN, this release constitutes a major change to the IMP program.
Because of the magnitude of the change, the system will be released on
an experimental basis.  If problems develop, then the current system,
IMPSYS 2514, will be reloaded and the cutover for IMPSYS 2600 will be
rescheduled for some later time.

     The actual transfer over to IMPSYS 2600 will require assis- tance
from site personnel, and we hereby request this assistance.  A new
tape of IMPLOD 2600 will be mailed to all sites shortly, and the staff
at BBN will request each site in turn on May 15 to load the new IMPLOD
tape and will detail other procedures to follow thereafter.  We prefer
that each site have someone who is familiar with IMP system operation
on hand at this time.  At some sites, we may request additional
assistance from the computer operations staffs or programmers in the
case of any problems.  We also advise site personnel to refrain from
scheduling produc- tion over the Network during the hours of
switchover, since unforeseen difficulties may arise.

     It is anticipated that the Hosts will not see any first- order
effects from the switchover.  Leader formats and message types are not
changed.  On the other hand, the statistics package has been
extensively modified, and the NMC has been notified of these changes.
The Very Distant Host option will also be included in this new system
release, and it is expected to be activated for use about June 1.  The
detailed changes to the IMP system will be described in a forthcoming
revision to BBN Report 1822.

     Finally, your patience is requested if the new system causes
unforeseen problems.


JMcQ/jm

       [ This RFC was put into machine readable form for entry ]
       [ into the online RFC archives by BBN Corp. under the   ]
       [ direction of Alex McKenzie.                   12/96   ]

ISO Plain Language

On this page
PROBLEMBBN planned a major IMP software release that could cause unforeseen problems during the network switchover.
MECHANISMThe notice schedules IMPSYS 2600 for May 15, 1972, asks sites to help load the new tape, and provides for reloading IMPSYS 2514 if problems develop.
HISTORICAL CONTEXTRFC 331 is an operational notice about the planned change and was obsoleted by RFC 343.

§1Planned Software Release

BBN planned to release IMPSYS 2600 on May 15, 1972, between noon and 3 p.m. E.D.T. The memo describes the release as a major change to the IMP program and says it would be experimental.

If problems developed, BBN would reload the current system, IMPSYS 2514, and reschedule the cutover.

BBN planned to test a major IMP software release on May 15. If it caused problems, the old system would be restored and the cutover delayed.

§2What Sites Were Asked to Do

BBN planned to mail a new IMPLOD 2600 tape to all sites. On May 15, BBN staff would contact each site in turn, ask personnel to load the tape, and provide further procedures. BBN preferred that someone familiar with IMP operations be present.

The memo advises sites not to schedule production over the Network during the switchover hours because unforeseen difficulties might arise.

Each site was expected to load the new tape when BBN called. Sites were asked to avoid production network work during the change.

§3Expected Effects

The notice anticipated no first-order effects for hosts because leader formats and message types were not changing. It says the statistics package had been extensively modified and that the Network Measurement Center had been notified.

The Very Distant Host option would be included in the new release and was expected to be activated around June 1. The detailed changes were to be described in a forthcoming revision to BBN Report 1822.

Hosts were not expected to need changes because message formats stayed the same. The statistics package changed, and the Very Distant Host option was expected to be activated later.